Программирование на языке Python, задача Гамбсовская мебель Захватило почему-то дух у Ипполита Матвеевича. Он отчетливо вспомнил гостиную в своем особняке, симметрично расставленную ореховую мебель с гнутыми ножками, начищенный восковой пол, старинный коричневый рояль и овальные черные рамочки с дагерротипами сановных родственников на стенах. И дюжину стульев, обитых английским ситцем в мелкий цветочек.
Однако не вся мебель одинаково дорога Ипполиту Матвеевичу, а только та, у которой больше 4 общих букв с заветным словом.
Напишите программу, которая из строки фраз, записанных через дефис, окруженный пробелами, выберет только подходящие.
Var K:array[1..2,1..13] of integer; i,j,ind,x,y:integer; MAX:real; function RAST(x1,x2,y1,y2:integer):real; begin RAST:=sqrt(sqr(x2-x1)+sqr(y2-y1)); end; begin MAX:=-2*sqr(-10-1); randomize; writeln('Исходные точки:'); for j:=1 to 13 do begin writeln('Точка № ',j,', с координатами(X,Y)'); for i:=1 to 2 do begin K[i,j]:=random(110) - 10; write(K[i,j],' '); end; writeln; end; for i:=1 to 13 do if RAST(0,K[1,i],0,K[2,i])>MAX then begin MAX:=RAST(0,K[1,i],0,K[2,i]); x:=K[1,i]; y:=K[2,i]; ind:=i; end; writeln('Номер точки: ',ind,' Координаты: ',x,' ; ',y); end.
var s: string; i, j, n: integer; c: char; flag: boolean;
begin Write('Введите произвольное число: '); Readln(s); flag := false; n := length(s); i := 1; while (i <= n) and (not flag) do begin c := s[i]; j := i + 1; while (j <= n) and (not flag) do if s[j] = c then flag := true else j := j + 1; if (not flag) then i := i + 1 end; if flag then Writeln('Символ "', c, '" встречается больше одного раза') else Writeln('Все символы уникальны') end.
Тестовое решение: Введите произвольное число: -1453.5462 Символ "4" встречается больше одного раза
K:array[1..2,1..13] of integer;
i,j,ind,x,y:integer;
MAX:real;
function RAST(x1,x2,y1,y2:integer):real;
begin
RAST:=sqrt(sqr(x2-x1)+sqr(y2-y1));
end;
begin
MAX:=-2*sqr(-10-1);
randomize;
writeln('Исходные точки:');
for j:=1 to 13 do
begin
writeln('Точка № ',j,', с координатами(X,Y)');
for i:=1 to 2 do
begin
K[i,j]:=random(110) - 10;
write(K[i,j],' ');
end;
writeln;
end;
for i:=1 to 13 do
if RAST(0,K[1,i],0,K[2,i])>MAX
then
begin
MAX:=RAST(0,K[1,i],0,K[2,i]);
x:=K[1,i];
y:=K[2,i];
ind:=i;
end;
writeln('Номер точки: ',ind,' Координаты: ',x,' ; ',y);
end.
s: string;
i, j, n: integer;
c: char;
flag: boolean;
begin
Write('Введите произвольное число: '); Readln(s);
flag := false;
n := length(s);
i := 1;
while (i <= n) and (not flag) do
begin
c := s[i];
j := i + 1;
while (j <= n) and (not flag) do
if s[j] = c then flag := true else j := j + 1;
if (not flag) then i := i + 1
end;
if flag then Writeln('Символ "', c, '" встречается больше одного раза')
else Writeln('Все символы уникальны')
end.
Тестовое решение:
Введите произвольное число: -1453.5462
Символ "4" встречается больше одного раза