В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lren1
lren1
31.07.2021 04:00 •  Информатика

Программирование

Зависимость задана функцией y(a,b), в которой одно из выражений y1 = (a+b)*(a-b), y2 = (a*b) является числителем, а другое- знаменателем. В знаменатель становится то из выражений, значение которого больше при введенных значениях.
Необходимо написать программу для любых a и b, вводимых с клавиатуры, учесть вариант отсутствия решений.

Пояснение: если y1 > y2 выражение принимает вид y = y1/y2, если y2>y1 - выражение принимает вид y = y2/y1. То есть результат всегда больше или равен 1.

Показать ответ
Ответ:
Hahanicejoke
Hahanicejoke
27.11.2020 06:29
Материнская плата – это самая основная плата в системном блоке, которая
определяет производительность компьютера. На материнской плате
устанавливаются основные устройства ПК: процессор, видеокарта, оперативная
память, чипсет, слоты, с шлейфов и кабелей к материнке
подключаться CD-Rom, жесткий диск, дисковод, клавиатура, мышь…
Чтобы правильно подобрать материнскую плату нужно хорошенько изучить
форм-фактор. Это такая плата, которая определяет размер, разъемы питания и
установочные отверстия материнки.
Форм-факторы для материнских плат:
• Advanced Technology eXtended – подходит идеально для сборки домашних ПК;
• micro ATX – подходит для офисных компьютеров;
• mini-ITX.
Чипсет – микросхема, которая обеспечивает подключение к оперативной памяти
процессора. Чипсеты состоят с «Южного» и «Северного» моста».
Сокет – это гнездо, куда на системной плате крепиться процессор.
Процесс выбора материнки:
• выбор поддерживаемого процессора.
• выбор чипсета;
• какие дополнительные функции поддерживает материнская плата;
• выбор производителя.
Все же главным производителем в материнской плате является брэнд. Хоть эти
материнки дороже, но компания зарабатывала свое имя годами, тому и качество
у них высокое.
Что бы Вы не купили, помните, главное в работе – это стабильность.
0,0(0 оценок)
Ответ:
svet0chka
svet0chka
21.07.2020 13:57
Const
  nn = 100;

var
  n, l1, l2, r1, r2, i: integer;
  a, b: array[1..nn] of integer;
  F: Text;

begin
  Assign(F, 'input.txt');
  Reset(F);
  Readln(F, n);
  for i := 1 to n do Read(F, a[i]);
  Readln(F, l1, r1);
  Readln(F, l2, r2);
  Close(F);
  for i := 1 to l1 - 1 do b[i] := a[i];
  for i := l1 to r1 do b[i] := a[l1 + r1 - i];
  if l2 <= r1 then
  begin
    for i := l1 to r1 do a[i] := b[i];
    for i := l2 to r2 do b[i] := a[l2 + r2 - i]
  end
  else
  begin
    for i := r1 + 1 to l2 - 1 do b[i] := a[i];
    for i := l2 to r2 do b[i] := a[l2 + r2 - i];
  end;
  for i := r2 + 1 to n do b[i] := a[i];
  for i := 1 to n do Write(b[i],' ');
end.

Результат решения:
5 8 3 6 0 14 -6 -2 4 1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота