В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
joeehazber
joeehazber
05.02.2023 10:30 •  Информатика

Программу через паскаль планы по благоустройству города иногда имеют свойство воплощаться в жизнь. вот, к примеру, раньше кеше, чтобы добраться до бассейна, приходилось переходить одну широкую дорогу. а теперь наземного перехода больше нет, зато есть подземный переход. правда, расстояние, которое приходится преодолевать по подземному переходу, в несколько раз больше, чем было по наземному. но есть и плюсы — бывает, начинает накрапывать дождь, а пока спустишься в переход, пройдёшь его, поднимешься — а дождь уже успел превратиться в ливень, пролиться, и выглянувшее солнце сушит лужи. маршрут кеши от дома до бассейна выглядит следующим образом. сначала кеша идёт по улице в течение d минут, потом идёт по подземному переходу в течение w минут, после чего вновь идёт по улице в течение p минут. известно, что, пока кеша шёл в бассейн дождь длительностью u минут. дождь начался не ранее момента, в который кеша вышел из дома, и закончился не позднее того момента, когда кеша дошёл до бассейна. ваша — определить, какое максимальное и какое минимальное время кеша мог идти под дождём. входные данные в первой строке содержатся целые числа d, w, p, u (1 ≤ d, w, p ≤ 1000, u ≤ d + w + p), описанные в условии . выходные данные выведите два целых числа — максимальное и минимальное время, которое кеша мог идти под дождём. пример входные данные 14 10 8 15 выходные данные 14 5

Показать ответ
Ответ:
Dec3mber
Dec3mber
03.10.2020 23:43
Var  d, w, p, u: integer;
begin  read(d);  read(w);  read(p);  read(u);  if u <= d + w then  begin    write(d, ' ');    write(u - w);  end  else if u > d + w + p then  begin    write(p + d,' ');    write(p + d);  end  else   begin    write(u - w,' ');    write(p);  end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота