Программу,решающую следующую : дано трёхзначное число.составить программу вывода на экран числа, полученного перестановкой цифр сотен и десятков. за 34
Var a,b,c: integer; Begin write('Ведите трёхзначное число: '); readln (a); b:=a div 100; c:=a mod 100 div 10; writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b) End.
Var a,b,c,d: integer; Begin write('Ведите трёхзначное число: '); readln (a); b:=a div 100; c:=a mod 100 div 10; d:=a mod 10; writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b,d) End.
e = n%10
d = n//10%10
s = n//100
print(d*100+s*10+e)
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b)
End.
Var a,b,c,d: integer;
Begin
write('Ведите трёхзначное число: ');
readln (a);
b:=a div 100;
c:=a mod 100 div 10;
d:=a mod 10;
writeln('Число, полученное перестановкой цифр сотен и десятков: ',c,b,d)
End.
(PascalABCNET)