Программы с условным оператором Определите значение переменной с после выполнения следующего фрагмента программы (записанного ниже на разных языках программирования). ответ запишите в виде целого числа.
БэйсикАлгоритмический язык
а = 50 b = 6 а = а * 3 / b IF а > b THEN с = а + 5 * b ELSE с = а - 5 * b END IF
a : = 50 b : = 6 a : = a * 3 / b если a > b TO с : = a + 5 * b иначе с := a - 5 * b все
Си++Паскаль
a =50; b = 6; a = a * 3 / b if (a > b) с = a + 5 * b; else с = a - 5 * b;
a : = 50 ; b : = 6; a : = a * 3 / b if a > b then с = a + 5 * b else с = a - 5 * b;
Python
a = 50
b = 6
a = a * 3 / b
if a > b:
c = a + 5 * b
else:
c = a - 5 * b
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
double x1, y1, x2, y2, x3, y3, a, b, c;
cout << 'Введите координаты точек треугольника: ';
cin >> x1;
cin >> y1;
cin >> x2;
cin >> y2;
cin >> x3;
cin >> y3;
a = sqrt(pow((x2 - x1), 2) + pow((y2 - y1), 2));
b = sqrt(pow((x3 - x2), 2) + pow((y3 - y2), 2));
c = sqrt(pow((x1 - x3), 2) + pow((y1 - y3), 2));
if (a = b = c) {
cout << "Данный треугольник - равносторонний\n";
}
else if (a == b || b == c || a == c ) {
cout << "Данный треугольник - равнобедренный\n";
}
else if (a != b && b != c && a != c) {
cout << "Данный треугольник - разносторонний\n";
}
if (c > a && c > b) {
if (c*c == a*a + b*b) {
cout << "Данный треугольник - прямоугольный";
}
else if (c*c < a*a + b*b) {
cout << "Данный треугольник - остроугольный";
}
else {
cout << "Данный треугольник - тупоугольный";
}
}
else if (a > b && a > c) {
if (a*a == b*b + c*c) {
cout << "Данный треугольник - прямоугольный";
}
else if (a*a < b*b + c*c) {
cout << "Данный треугольник - остроугольный";
}
else {
cout << "Данный треугольник - тупоугольный";
}
}
else {
if (b*b == a*a + c*c) {
cout << "Данный треугольник - прямоугольный";
}
else if (b*b < a*a + c*c) {
cout << "Данный треугольник - остроугольный";
}
else {
cout << "Данный треугольник - тупоугольный";
}
}
}
Багато користувачів вважають, що якщо фотографії викладені в мережу, їх автори надали дозвіл на їх вільне використання. Такі міркування є помилковими, та призводять до порушення законодавства України про авторські та суміжні права. Тому важливо знати правила, які охороняють твори та їх авторів від протиправних посягань з боку інших осіб.
Про відповідальність за порушення законодавства про авторські права та захисту своїх прав інтелектуальної власності розповідає фахівчиня Першого одеського бюро правової до Ірина Кисельова.
Одним з поширених порушень авторського права є протиправне розміщення письмового твору автора в мережі Інтернет. Захищати власні права важливо: ставлення до таких кейсів може стати серйознішим, якщо вони частіше будуть з’являтися в інформаційному просторі.