В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Бронвин
Бронвин
08.03.2022 01:10 •  Информатика

Пусть дано некоторое целое число. требуется составить программу, которая выводит на экран монитора сообщение о том, какое это число: положительное либо отрицательное. и если это число положительное, уменьшает его в 2 раза, в противном случае возводит его в квадрат.

Показать ответ
Ответ:
vovkatop228
vovkatop228
28.07.2020 10:57
Program a2;
var a,b:integer;
begin
 write('Введите целое числo');
 readln(a);
  if a > 0 then  begin
 b:=a div 2;                                   
  end
  else
 begin b:=a*a;
                 end;
  write ('b',b);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота