В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dudinaksusha06
dudinaksusha06
01.01.2022 00:04 •  Информатика

Пусть задан массив из 20 элементов, содержащию информацию о 20 участниц конкурса красоты ( точнее, количество набранных ими очков). Призы выдаются обычно следующим образом: сначала 10-е место, затем 9-е, затем 8-е, и так до 1-го. А второй десяток остаётся по возрастанию. Составьте программу, которая распределит результаты по этому алгоритму и выведет их на экран. В C++

Показать ответ
Ответ:
StenxgenS
StenxgenS
14.09.2020 17:28

#include <iostream>

using namespace std;

#define ll long long

#define ld long double

signed main(){

   const ll n = 20;

   ll a[n];

   for(ll i = 0; i < n; i++)

       cin >> a[i];

   sort(a,a+n);

   ll cur_place = 10;

   for(ll i = 10; i < 20; i++){

       cout << cur_place <<"th place reached: " << a[i] << " scores" << "\n";

       cur_place--;

   }

   cur_place = 11;

   for(ll i = 0; i < 10; i++){

       cout << cur_place <<"th place reached: " << a[i] << " scores" << "\n";

       cur_place++;

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота