В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
denishr06
denishr06
08.03.2023 07:36 •  Информатика

Python ! 1) Сгенерировать список из 10000 случайных элементов, значения от 0 до 99 (через бибилотеку random),
после чего вывести среднее арифметическое этих элементов,
сумму всех элементов, которые делятся на 10 без остатка и если сумма этих элементов меньше 600, вывести значение последнего элемента массива.
2) Написать программу, которая на вход получает слово, и добавляет к нему восклицательный знак, выовдит получившуюся строку.

Показать ответ
Ответ:
3231561
3231561
03.04.2021 14:20

1)import random

s = [random.randint(0,99) for i in range(10000)]

sum = 0

for i in s:

   sum += i

print("Среднее арифметическое:", sum/10000)

sum = 0

for i in s:

   if i % 10 == 0:

       sum += i

if sum < 600:

   print(s[len(s)-1])

else:

   print("Сумма всех элементов, которые делятся на 10 без остатка:",sum)

2)s = input()

print(s+"!")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота