В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KatyaCat69
KatyaCat69
18.05.2021 20:17 •  Информатика

Python 3 Most frequent

У вас есть массив чисел длиною "N". Нужно найти элемент в массиве, которое встречается наибольшее количество раз.

Входные данные:

(1 ≤ n ≤ 10000), где каждый элемент в массиве в промежутке (-10000 ≤ a[i] ≤ 10000)

Выходные данные:

Нужно найти элемент в массиве, которое встречается наибольшее количество раз.
Пример 1
Ввод:
7
0 0 0 0 58 0 0

Вывод:
0
Пример 2
Ввод:
9
100 100 55 100 89 100 100 100 100

Вывод:
100
Пример 3
Ввод:
9
19 19 19 64 50 19 19 19 19

Вывод:
19

Показать ответ
Ответ:
anastasiyabalk1
anastasiyabalk1
10.05.2020 11:01
Uses crt;
var r: array [1..10] of integer;
      nev, n, min,i, zap:integer;
begin
   clrscr;
   write('Введите возраст невесты: '); readln(nev);
   write('Введите число женихов: '); readln(n);
   if n<2 then
   for i:=1 to n do
   begin
   write('Введите возраст ',i,'-го жениха: '); readln(r[i]);
   end;

   i:=0; zap:=0;
   while (zap=0) and (i<=n) do begin  
     i:=i+1;
     min:=nev-r[i];
     if min>0 then zap:=i;
   end;
   if i<>n then
   begin
     for i:=zap to n do
     begin
        if min>(nev-r[i]) then
        begin
           zap:=i;
           min:=nev-r[i];
         end;
     end;
     writeln('Самый молодой жених старше невесты в возрасте ',r[zap], ' лет. Разница в возрасте составляет ', min, ' лет.');
     writeln ('По счету это ',i,'-ый жених');
   end
   else writeln('Среди женихов нет подходящего для нашей невесты.');
  end;
  else writeln('Число женихов должно быть более 2!');
end.
     
0,0(0 оценок)
Ответ:
hovrashok
hovrashok
16.01.2023 17:47
Бесконечность – не предел! Этот девиз из известного высказывания Стива Джобса как нельзя лучше отражает происходящее в настоящее время проникновение прогрессивных технологий в жизнь человека. Современная физика предполагает, что в основе окружающей человека реальности лежит бесконечность. Перед бесконечностью все равны и кибернетический суперинтеллект будущего и человек с его недостатками, всем есть экологическая ниша для жизни. Будущее принадлежит не человеку и не роботу, а своеобразному кентавру – человеко-машинному комплексу. Из выше сказанного тривиально следует команду назвать: Кентавры.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота