PYTHON 3
Спортсмены соревнуются в метании ядра. N спортсменов совершили броски ядра. Количество бросков каждого из спортсменов отличается. Вам нужно написать программу, которая определит какой из спортсменов дальше всех забросил ядро.
Вводные данные: в первой строке дается число N, количество спортсменов которые участвуют в метании ядер. Затем на N строках, первым идет имя спортсмена, затем через пробел значения каждого совершённого броска данного спортсмена.
Выходные данные: на одной строке через пробел, имя спортсмена который совершил максимальный бросок и значение броска. Если множество спортсменов совершили максимальный бросок, то вывести первого из них который совершил данный бросок.
Пример 1
Ввод:
3
Askhat 23 12 45
Elnur 45 32 23
Nurbek 34 45 34
Вывод:
Askhat 45
начнём с того,что s трапеции-это 1/2 a*h (1/2 основания на высоту).
теперь,с этими знаниями,переходим в pascal abc.net.
начинаем с названия программы.
program pltrap; (pltrap-это сокращенно площадь трапеции.если хочешь,можешь написать за место этого то,что хочешь ты).
задаем переменные.
var a,b,c: real; (а-это высота,b-это средняя линия,с-сама площадь трапеции. real-тип переменных чисел.real-значит число может быть как целым,так и не целым).
begin - (начало решения).
возьмем наши переменные,которые будем записывать в строку.
readln(a); - высота.
readln(b); - основание.
c: =0.5*a*b - это наша формула для нахождении площади.1/2-это 0,5.в паскале нужно писать в целых числах вместо запятой точку.
writeln(c); - это то,что нам надо найти,то,что высветится,как ответ,в окне вывода.в нашем случае-это площадь.
end. - конец программы (на конце ставим точку).
итак,что у нас получилось:
program pltrap;
var a,b,c: real;
begin
readln(a);
readln(b);
c: =0.5*a*b;
writeln(c)
end.
теперь пишем в окно ввода числа.
первое число-это a (высота),потому что мы ее задали первой в команде readln(a);
потом-b (основание).
и получаем,чему будет равна площадь.например.пишем числа:
10
2
s=1/2*a*c=0,5*10*2=10- это число выдаст паскаль.
не забывай про ;
если будут вопросы-пиши мне.
var j, a, b, n: integer;
label 1;
begin
1: randomize;
a: = random (9);
b: = random (9);
write (a, '*', b, '=');
read (n);
if n = (a * b) then writeln ('відповідь вірний! ')
else writeln ('відповідь неправильний! ');
writeln ('продовжуватимеш? ');
writeln ('якщо так то натисни 1');
writeln ('якщо немає то натисни 2');
read (j);
if j = 1 then goto 1;
if j = 2 then writeln ('до побачення! ');
end.
начебто так, точно не пам'ятаю.