В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
anyapletneva0
anyapletneva0
09.04.2022 09:07 •  Информатика

Python. Циклы for и while. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). 30 б.

Показать ответ
Ответ:
elizapanfilova1
elizapanfilova1
17.03.2021 22:13

x, s, counter = -1, 0, 0

while x != 0:

   x = int(input())

   if (x>=100) and (x<=999):

       s += x

       counter += 1

if counter == 0:

   print("NO")

else:

   print(s/counter)

0,0(0 оценок)
Ответ:
ирввадрпраз
ирввадрпраз
17.03.2021 22:13

numbers = []

while True:

   num = int(input('Введите число: '))

   if num == 0:

       break

   if len(str(num)) == 3:

       numbers.append(num)

if numbers != []:

   s = 0

   for num in numbers:

       s += num

   print('Среднее арифметическое:', s / len(numbers))

else:

   print('NO')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота