В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kli200192uasmi
kli200192uasmi
18.09.2020 23:45 •  Информатика

Python Junior
Задание 1
Даны два целых числа. Выведите значение наименьшего
из них.
Задание 2
В математике функция sign(x) (знак числа) определена так:
sign(x) = 1, если x > 0,
sign(x) = -1, если x < 0,
sign(x) = 0, если x = 0.
Для данного числа x выведите значение sign(x).
Задание 3
(Дополнительное, на высокую оценку)
Заданы две клетки шахматной доски. Если они покрашены в один цвет, то выведите слово YES, а если в разные
цвета – то NO.
Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки – сначала для
первой клетки, потом для второй клетки.

Показать ответ
Ответ:
oleg1960
oleg1960
07.03.2022 21:28
Если я понял о чем ты, то вот:
var
x, y, b: integer; // описание переменных

begin // начало программы 
write ('y = x*b ');  
read(x,b);      // ввод переменной x,b

if x > 0   // проверка, х больше от 0?
then   
y := y * b       // если да, то исполняется это
else               
if x = 0 then   //если нет, то это(тут опять же проверка, х равно 0?)
y := 0             // если да то "y" присваивается 0
else
y := abs(x);    // если нет то "y" присваивается значение модуль "х"

writeln ('y = ', y);  // выводятся значения,

end. // завершение программы
Переведите на , var x, y, b: integer; begin write ('y = x*b '); readln (x); if x > 0 then y : = y
0,0(0 оценок)
Ответ:
winterwhite123
winterwhite123
02.08.2020 10:49
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота