В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
morti3
morti3
08.08.2020 22:44 •  Информатика

Python множества

Напишите программу, которая удаляет из строки все повторяющиеся символы.
Входные данные
На вход программы подаётся строка, содержащая символы таблицы ASCII.
Выходные данные
Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Показать ответ
Ответ:
agarkovatanech
agarkovatanech
12.08.2020 07:49

element_list = input().split()

for l in element_list:

   print(l, end = ' ') # до сортировки

for elem in element_list:

   if element_list.count(elem) != 1:

       for i in range(element_list.count(elem)):

           element_list.remove(elem)

for n in element_list:

   print(n, end = ' ') # после сортировки

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота