PYTHON
Монеты
На столе лежат N монеток. Некоторые из них лежат вверх решкой, а некоторые – гербом. Определите минимальное число монеток, которые нужно перевернуть, чтобы все монетки были повернуты вверх одной и той же стороной.
Входные данные
В первой строке записано натуральное число N (1 ≤ N ≤ 100) – число монеток. В каждой из последующих N строк содержится одно целое число – 1 если монетка лежит решкой вверх и 0 если вверх гербом.
Выходные данные
Выведите минимальное количество монет, которые нужно перевернуть.
Пример 1
Ввод:
8 1 0 1 0 1 0 0 0
Вывод:
3
1.
составной оператор - это скобки begin...end (в С образных языках для это используются реальные скобки {}) которые позволяют объединить несколько команд под одним оператором
if a > b then begin
с:=1;
d:=2;
end
else begin
c:=3;
d:=4;
end
2.
var
a,b,c,max:integer;
begin
writeln('Введите возраст призеров:');
readln(a,b,c);
if (a < b) and (a < c) then
begin
max := a;
writeln('Самый младший - первый призер, ему ',max,' лет.');
end;
if (b < a) and (b < c) then
begin
max := b;
writeln('Самый младший - второй призер, ему ',max,' лет.');
end;
if (c < a) and (c < b) then
begin
max := c;
writeln('Самый младший - третий призер, ему ',max,' лет.');
end;
end.
ответ: Проверенно
Этот код преднозначен для решения этого примера 'если a>b, то , иначе p^2=z'
x-3/x^2-2x+5
Program jnj;
var
a, b: real;
bool: boolean;
begin
writeln('Введите значение a:');
readln(a);
writeln('Введите значение b:');
readln(b);
begin
if a > b then
writeln(a - 3 / sqr(a) - 2*a + 5) end;
begin
if a <= b then
writeln('z = ', sqr(b));
end;
end.
program jnj;
Этот код преднозначен для решения корень y+x=z
var
y, x: real;
begin
writeln('Введите y:');
readln(y);
writeln('Введите x:');
readln(x);
writeln('z = ', sqrt(y + x), ';');
end.
Оба кода разные, поэтому вводить их нужно поочередно