В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
кпеп
кпеп
15.03.2021 06:34 •  Информатика

(Python) написать программу, которая считывает числа, вводимые пользователем, пока пользователь не введёт слово “end”. Предполагайте, что пользователь вводит только целые числа или слово “end”. В конце программа должна вывести все введённые числа через запятую и их сумму и среднее значение.
Пример вывода
Enter numbers:
1
10
25
-1
0
3
67
end
You entered: 1, 10, 25, -1, 0, 3, 67
Total: 105
Average: 15.0
Указания:
Используйте цикл while для ввода чисел и сохраняйте их в списке.
Используйте цикл for для подсчёта суммы чисел в полученном списке.

Показать ответ
Ответ:
maxim5251988
maxim5251988
12.10.2020 10:08

lst = []

count = 0

sm = 0

while True:

   try:

       lst += [int(input())]

   except:

       break

print('You entered:', end=' ')

for i in lst:

   sm += i

   count += 1

   if i != lst[-1]:

       print(i, end=', ')

   else:

       print(i)

print(f'Total: {sm}')

print(f'Average: {sm / count}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота