В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
холера673
холера673
02.02.2023 17:52 •  Информатика

Python. Напишите программу, которая находит в матрице строку с минимальной суммой.
Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество
столбцов M (1 ≤ N, M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой
– по M натуральных чисел, разделённых пробелами.
Выходные данные
Программа должна вывести все элементы найденной строки с минимальной суммой,
разделив их пробелами. Если строк с одинаковой минимальной суммой несколько, нужно
выбрать из них строку с минимальным индексом.
Примеры
Входные данные
4 5
1 3 2 54 234
75 12 3 46 9
13 26 56 9 12
14 90 897 6 34
Выходные данные
13 26 56 9 12

Показать ответ
Ответ:
Натульчик67
Натульчик67
19.03.2022 12:20

x = list(map(int, input().split()))

arr = []

index = 0

res = 0

for i in range(x[0]):

    arr.append(list(map(int, input().split(

for i in range(x[0]):

    temp = 0

    for y in range(x[1]):

        temp+= arr[i][y]

    if res == 0 or temp < res:

        res = temp

        index = i

print(*arr[index], sep=' ')

Надеюсь как-то

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота