В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
raiskadem
raiskadem
17.04.2023 00:00 •  Информатика

PYTHON/Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет
(выводит «NO»). Программа получает на вход количество чисел в
последовательности, а затем сами числа.
Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет

Показать ответ
Ответ:
galinadik84
galinadik84
10.03.2021 19:29

n = int(input())

a = list(map(int, input().split()))

num_sum = 0

num_count = 0

for x in a:

   if x % 8 == 0:

       num_sum += x

       num_count += 1

if num_count:

   print(num_sum/num_count)

else:

   print('NO')


PYTHON/Напишите программу, которая в последовательности натуральных чисел находит среднее арифметиче
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота