В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
buckubarnes17
buckubarnes17
08.05.2023 20:26 •  Информатика

Python Напишите программу, в которой пользователь вводит строки до тех пор, пока не будет введена пустая строка "".  При вводе каждой непустой строки, программа должна выводить "текст". 

Входные данные:

Ввод текста в отдельных строчках.

Выходные данные:

Выводить "текст" до пустой строки.​

Показать ответ
Ответ:
лааллввлллаалв
лааллввлллаалв
15.10.2020 15:23

--- Python 3.8.3 ---

import typing

from typing import Callable

from typing import Any

Primitive = typing.TypeVar('Primitive', int, float, complex, str, bytes, bytearray)

def ReadSeqWhile(predicate: Callable[[Any], bool], SeqType: Primitive = int):

   '''

   Возвращает последовательность элементов в указанном типе, считываемых с клавиатуры, пока ввод удовлетворяет условию

   '''

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   InputData = ReadSeqWhile(lambda p: p != '', SeqType = str)

   for _ in InputData:

       print('text')

   

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота