В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dec3mber
Dec3mber
25.06.2020 03:58 •  Информатика

[Python]Разработать алгоритм и программу решения следующей задачи. Найдите максимальное значение функции y=Cosx/Sinx на отрезке [a,b] с шагом h.

Показать ответ
Ответ:
dumbschoolkid
dumbschoolkid
15.12.2020 15:02

import math

a,b,h = int(input()),int(input()),int(input())

maxx = 0

for x in (a,b+1,h):

   y = math.cos(x)/math.sin(x)

   maxx = max(maxx,y)

print(maxx)

Объяснение:


[Python]Разработать алгоритм и программу решения следующей задачи. Найдите максимальное значение фун
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота