В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
uliana3447
uliana3447
27.05.2020 04:41 •  Информатика

Python тема-While Метеоролог – это человек, собирающий и фиксирующий информацию о погодных явлениях.

Наш метеоролог несколько дней подряд измеряет температуру воздуха в вашем городе. Ваша программа считывает измеренные им значения и выводит среднее значение температуры за время измерений. Чтобы обозначить конец ввода данных, вводится значение, меньшее -100 (Абсолютный минимум −93.2 °C был зафиксирован в Антарктиде 10 августа 2010 г., в вашем городе точно не холоднее) или больше +80 (Абсолютный максимум +70.7 °C — в 2005 году в солончаковой пустыне Деште-Лут на юго-востоке Ирана).

Входные данные:

Ввод температуры воздуха на отдельных строках. На одной из строк обязательно содержится значение < -100 или >80.

Выходные данные:Одно число - средняя температура за период измерений, округленное до сотых.​

Показать ответ
Ответ:
oksanochkabob
oksanochkabob
15.10.2020 15:27

--- Python 3.8.3 ---

ABS_MIN = -100

ABS_MAX = 80

summ, length = 0, 0

input_ = float(input())

while (input_ <= ABS_MAX and input_ >= ABS_MIN):

   summ += input_

   length += 1

   input_ = float(input())

print(round(summ/length, 2))

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота