В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lyda777
lyda777
11.10.2020 22:46 •  Информатика

Python У Саши на компьютере есть папка, где он хранит все свои фото для будущих публикаций. У каждого фото в этой папке есть особое название - семизначный номер.

В этом номере каждая цифра обозначает актуальность фото для определенной аудитории. Сейчас Саша хочет разделить семизначное число на цифры и выписать их в столбик с текстовыми пометками "популярно" (если число больше или равно 7) или "мимо" (если число меньше 7).

Формат входных данных
Семизначное целое положительное число N.

Формат выходных данных
Все цифры числа, начиная с единиц, каждое в отдельной строке. Рядом с цифрой слово "популярно" или "мимо" (в зависимости от цифры).

Показать ответ
Ответ:
elyakomarova0
elyakomarova0
21.03.2022 12:40

n = int(input())

while n:

   a = n % 10

   s = 'популярно' if a >= 7 else 'мимо'

   print(a, s)

   n //= 10

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота