В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
HastWay
HastWay
17.08.2021 15:10 •  Информатика

PYTHON

: В игре «Русское лото» из мешка случайным

образом выбираются бочонки, на каждом из которых

написано число от 1 до 90. Напишите программу,

которая выводит наугад первые 5 выигрышных

номеров.

«B»: Доработайте программу «Русское лото» так,

чтобы все 5 значений гарантированно были бы

разными (используйте разные диапазоны).

Показать ответ
Ответ:
ivan497
ivan497
23.06.2022 01:05
Var
  a: array [1..10] of byte;
  i, k, n, t, x, max: byte;
  //процедура вывода массива
procedure WriteA();
var i : byte;
begin  for i := 1 to 10 do begin
    write(a[i], chr(32));
  end;
  writeln();
end;
//основная процедура
begin 
Randomize;
  for i := 1 to 10 do begin
    a[i] := random(100);
  end;
  WriteA();
  writeln('');
  n := 10;
  while n > 1 do begin
    for i := n downto 1 do begin
      if a[i] > max then begin max := a[i]; x := i end;
    end;
    t := a[n];
    a[n] := max;
    a[x] := t;
    dec(n);
    max := 0;
    WriteA();
  end;
  writeln('');
  WriteA();
end.

- Pascal ABC.NET, массив из 10 случайных чисел до 100 типа byte
- Результат работы программы следующий:

43 77 72 39 60 99 44 65 72 58
 
43 77 72 39 60 58 44 65 72 99
43 72 72 39 60 58 44 65 77 99
43 72 65 39 60 58 44 72 77 99
43 44 65 39 60 58 72 72 77 99
43 44 58 39 60 65 72 72 77 99
43 44 58 39 60 65 72 72 77 99
43 44 39 58 60 65 72 72 77 99
43 39 44 58 60 65 72 72 77 99
39 43 44 58 60 65 72 72 77 99
 
39 43 44 58 60 65 72 72 77 99 
0,0(0 оценок)
Ответ:
shchepelevason
shchepelevason
14.04.2021 14:54
Решение на паскаль.
начало решения задач одинаковое, а дальше см. внизу

program xxx;
var b: array [1..6, 1..6] of integer;
 i, j, s : integer;
begin
for i:= 1 to 6 do
for j:=1 to 6 do
 b[i,j]:= random(131)-65;
writeln ('исходная матрица В:');
for i:=1 to 6 do
  begin
   for j:=1 to 6 do
     write (b[i,j]:4);
   writeln
 end;

задание 1.
s:=0;
for i:= 1 to 6  do
  if b[i,3]>0 then s:=s+b[i,3];
writeln ('сумма положительных элементов 3-го столбца', s)
end.

задание 2.
i:=2;
while i<=6 do begin
  for j:= 1 to 6 do
    if b[i,j]<0 then b[i,j]:=0;
  i:=i+2
end;
writeln ('полученная матрица В:');
for i:=1 to 6 do
  begin
   for j:=1 to 6 do
     write (b[i,j]:4);
   writeln
 end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота