В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dimannn8980
dimannn8980
22.01.2021 23:22 •  Информатика

Python В качестве входных данных для Вашей программы выступает одна строка с текстом заранее неизвестной длины, но не короче одного символа и не длиннее 100 символов. Напишите программу, которая бы выводила на экран одно целое число - сумму порядковых номеров в таблице Unicode первого и последнего символов полученной строки.
Если будет введена строка из одного символа, то первый символ следует одновременно считать последним.
На вход программе подаётся одна строка, длина которой не меньше 1 и не больше чем 100 символов.
На выходе программы должно быть единственное натуральное число, являющееся суммой порядковых номеров первого и последнего символов, содержащихся в поданной на вход строке.
Например, в тексте "ABCDE" нужно найти сумму порядковых номеров символа "А" и символа "Е". Это число равно 134 (сумма 65 и 69).

Показать ответ
Ответ:
яАРтеМоНкА
яАРтеМоНкА
05.08.2022 00:44

На Scratch компьютерные программы создаются практически как конструктор LEGO: на экране собираются графические блоки, которые управляют анимированными героями. Таким образом можно создать историю или игру и контролировать поведение разных героев, соединяя графические блоки. Точно так же как из конструктора LEGO собирают различные конструкции, на Scratch можно создавать интерактивные истории и игры, а потом, что важно, делиться ими с ребятами по всему миру на сайте Scratch.

Scratch – это простой и доступный всем в использовании язык программирования

0,0(0 оценок)
Ответ:
lflflflfgh
lflflflfgh
28.11.2022 02:46

1)

#include < iostream >

#include < cmath >

using namespace std;

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   double sum=0;

   int arr[6] = {12, 15, 20, 25, 59, 79};

   for(int i = 0; i < sizeof(arr)/ sizeof(arr[0]); i++)

       sum += arr[i];

   cout << sum/sizeof(arr)/ sizeof(arr[0]);

}

2)

#include < iostream >

#include < cmath >

using namespace std;

int fac(int n)

{

   if(n == 1)

       return 1;

   return n * fac(n-1);

}

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   int n;

   cin >> n;

   cout << fac(n);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота