В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
SsuccesS
SsuccesS
29.05.2021 07:14 •  Информатика

(Python) Вам нужно написать программу, которая за ввести оценки для четырёх учеников: Bill, Jane, John, Mary. В конце необходимо вывести среднюю оценку для всей группы, округлённую в большую сторону. Предполагайте, что пользователь вводит только числа в оценки. Средняя оценка вычисляется как среднее арифметическое - сумма всех оценок, делённая на количество учеников.
Что должно присутствовать в коде программы:

Каждую оценку нужно сохранять в словаре marks. В качестве ключей использовать имена учеников.
Для подсчёта суммы обращаться к каждой записи в словаре по ключу.

Показать ответ
Ответ:
kris0603
kris0603
12.10.2020 08:08

marks = {'Bill': int(input()), 'Jane': int(input()), 'John': int(input()), 'Mary': int(input())}

average = 0

for key in marks.keys():

   average += marks[key]

print(round(average / 4))

'округлённую в большую сторону'

Если нужно округлять всегда в большую сторону(то есть из 4.1 выводить среднюю 5), то в начале программы пишешь:

import math

, а в конце вместо 'print(round(average / 4))', пишешь:

print(math.ceil(average / 4))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота