Pythonмне нужна , мне нужно написать программу которая будет задавать вопросы та выдавать ответы, если ответ правильный то говорит что «правильно »а если нет то «ответ неверный »примерно 5 вопросов
11) 2,3; 12) 4 (1 байт (1 байт-8 бит-2^8=256 вариаций)); 13) 2 14) 1 (чорно-біле зображення - 1 біт на точку. 100х100х1=10,000 біт.) 15) на один ЧБП приходится 4 біта, тому що 2 в 4-ій степені - це і єсть 16. Маємо 10*10 точок, тобто 100 ЧБП. Отде, файл має рощмір 4 біта помножити на 100 = 400 біт (10*10*4=400) 16) 5 (для того, щоб краще зрозуміти, візьмемо малюнок із однієї точки чорної або білої. 0-чорна, 1-біла, потрібен 1 біт інформації. Тепер, будемо кодувати точку із 4 кольорів: 0 0 - чорна, 0 1 - біла, 1 0 - червона, 1 1 синя. Потрібно 2 біта (дві ячейки, які можуть бути 1 або 0). Для точки із 8 кольорів потрібно 3 біта, (три ячейки 1 або 0) для точки із 16 кольорів потрібно 4 біта (2 в четвертій степені). Щоб закодувати чисто 256 кольорів, потрібно 8 біт (2 в восьмій степені). Щоб закодувати 100 точок (10*10=100), потрібно 8*100 =800 біт. 17) 3 18) 3 19) 3 20) 2,5
12) 4 (1 байт (1 байт-8 бит-2^8=256 вариаций));
13) 2
14) 1 (чорно-біле зображення - 1 біт на точку. 100х100х1=10,000 біт.)
15) на один ЧБП приходится 4 біта, тому що 2 в 4-ій степені - це і єсть 16. Маємо 10*10 точок, тобто 100 ЧБП. Отде, файл має рощмір 4 біта помножити на 100 = 400 біт (10*10*4=400)
16) 5 (для того, щоб краще зрозуміти, візьмемо малюнок із однієї точки чорної або білої.
0-чорна, 1-біла, потрібен 1 біт інформації.
Тепер, будемо кодувати точку із 4 кольорів: 0 0 - чорна, 0 1 - біла, 1 0 - червона, 1 1 синя. Потрібно 2 біта (дві ячейки, які можуть бути 1 або 0).
Для точки із 8 кольорів потрібно 3 біта, (три ячейки 1 або 0)
для точки із 16 кольорів потрібно 4 біта (2 в четвертій степені).
Щоб закодувати чисто 256 кольорів, потрібно 8 біт (2 в восьмій степені).
Щоб закодувати 100 точок (10*10=100), потрібно 8*100 =800 біт.
17) 3
18) 3
19) 3
20) 2,5
signed main(){
int n, m;
cin >> n >> m;
vector<vector<int>> a(n, vector<int> (m));
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++)
cin >> a[i][j];
int col = 0, mx = a[0][0];
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++){
if(a[i][j] > mx){
mx = a[i][j];
col = j;
}
}
}
for(int i = 0; i < n; i++)
swap(a[i][0], a[i][col]);
for(int i = 0; i < n; i++){
for(int j = 0; j < m; j++)
cout << a[i][j] << " ";
cout << "\n";
}
}