В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sveronika00
sveronika00
29.03.2023 21:34 •  Информатика

Работа с матрицами. Составить программу на языке C (СИ) Создать квадратную матрицу целых чисел размером 9х9. В индивидуальных
заданиях указано, какую обработку матрицы требуется выполнить.
Если по условию задания матрицу следует заполнить случайными числами, рекомендуем
выбирать эти числа из диапазона 0 – 99. Если по условию задания в матрицу следует записать
ЛП — линейную последовательность чисел, имеется в виду последовательность: 1, 2, 3,
...


Работа с матрицами. Составить программу на языке C (СИ) Создать квадратную матрицу целых чисел разме

Показать ответ
Ответ:
fox16319
fox16319
24.12.2021 06:00

Відповідь:

include<stdio.h>

int main(){

unsigned int matrix[9][9]={0},a=1,b=8,t=1;

 

  for(int j=0;j<9;j++){

  for(int y=a;y<b;y++){

   matrix[y][j]=t;

   t++;

   

  }

  if(j>=0&&j<=3){

  a++;b--;}

  else{

  a--;b++;

  }}

 for(int i=0;i<9;i++){

  for(int j=0;j<9;j++){

   printf("%i\t",matrix[i][j]);

  }

  printf("\n");

 }

 

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота