В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lizadruzhinina1
lizadruzhinina1
15.01.2022 12:24 •  Информатика

Работаем в pascalabc.нужно составить программу,которая строит изображения предмета в плоском зеркале(расстояние от предмета до зеркала вводятся с клавиатуры). заранее )

Показать ответ
Ответ:
236784
236784
30.09.2020 19:47

Картинка должна находиться в папке программы и иметь расширение .jpg. У меня по умолчанию название папки PABCWork.NET. И размер картинки бери не большой))

 

 

 

 

 

uses
graphabc;
var
a:string;
b:picture;
c:integer;
begin
writeln('Введите расстояние до зеркала');
readln(c);
writeln('Введите имя файла рисунка (.jpg): ');
readln(a);
window.Clear;
b := Picture.Create(a);
b.Load(a);
b.Draw(50, 50);
b.FlipHorizontal;
b.Draw(300+5*c,50);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота