В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
leria11111111111
leria11111111111
21.04.2023 12:52 •  Информатика

Ребят с задачами, с ++, заранее Напишите программу, которая во всех возможных последовательностях длиной пять, составленных из трёх различных букв находит цепочку с заданной позицией. На вход программы в первой строке подаётся набор из трёх различных заглавных латинских букв, в алфавитном порядке. Во второй строке вводится номер искомой цепочки символов. Программа должна вывести цепочку с этим номером, если считать, что все последовательности расположены в лексикографическом (алфавитном) порядке. Последовательности пронумерованы, начиная с 1.

Sample Input 1:

ABC
15
Sample Output 1:

AABBC
Sample Input 2:

XYZ
242
Sample Output 2:

Y
Дано поле 10x10 для игры в "Сапёр". Поле заполнено нулями. В некоторых клетках стоят девятки -- мины.
Напишите программу, которая в каждой, не занятой миной клетке, пишет число от 0 до 8 -- количество мин, которые расположены в смежных клетках.
Sample Input 1:

0 0 0 0 9 9 0 0 0 0
0 0 0 0 0 9 0 0 0 0
0 0 0 0 0 0 0 9 0 0
0 0 0 0 0 0 0 9 0 0
0 0 0 9 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 9 0 9
0 0 0 0 0 0 0 0 0 0
9 0 0 0 9 0 0 0 0 0
0 0 0 0 0 0 0 0 9 0
Sample Output 1:

0 0 0 1 9 9 2 0 0 0
0 0 0 1 3 9 3 1 1 0
0 0 0 0 1 1 3 9 2 0
0 0 1 1 1 0 2 9 2 0
0 0 1 9 1 0 1 1 1 0
0 0 1 1 1 0 1 1 2 1
0 0 0 0 0 0 1 9 2 9
1 1 0 1 1 1 1 1 2 1
9 1 0 1 9 1 0 1 1 1
1 1 0 1 1 1 0 1 9 1
Sample Input 2:

0 0 0 0 0 0 0 0 0 0
0 0 0 9 9 9 0 0 0 0
0 0 0 9 9 9 0 0 0 0
0 0 0 9 9 9 0 0 0 0
0 0 0 0 0 0 0 0 0 0
0 0 0 9 9 9 9 9 0 0
0 0 0 0 0 0 0 0 0 0
9 9 9 0 0 0 0 0 0 0
9 0 9 0 0 0 0 0 0 0
9 9 9 0 0 0 0 0 0 9
Sample Output 2:

0 0 1 2 3 2 1 0 0 0
0 0 2 9 9 9 2 0 0 0
0 0 3 9 9 9 3 0 0 0
0 0 2 9 9 9 2 0 0 0
0 0 2 4 6 5 4 2 1 0
0 0 1 9 9 9 9 9 1 0
2 3 3 3 3 3 3 2 1 0
9 9 9 2 0 0 0 0 0 0
9 8 9 3 0 0 0 0 1 1
9 9 9 2 0 0 0 0 1 9
Напишите программу, которая запрашивает две строки, представляющие собой двоичные числа, и выводит в первой строке большее из них, а во второй строке -- меньшее. Числа подаются на вход без ведущих нулей. Длина чисел -- не более 1000 разрядов.
Sample Input 1:

1001
1101
Sample Output 1:

1101
1001
Sample Input 2:

100
11
Sample Output 2:

100
11
Напишите программу, которая выводит все решения ребуса VOLVO+FIAT=MOTOR в лексикографическом порядке. Одинаковым буквам соответствуют одинаковые цифры. Разным буквам соответствуют разные цифры. Решения надо пронумеровать, отделяя номер от ответа знаком табуляции "\t".

Показать ответ
Ответ:
erke22
erke22
27.05.2021 07:46

ЯП: С++ | можно не писать std:: , если использовать пространство имен: using namespace std;

#include <iostream>

int main() {

const int SIZE = 10;

int regim, sum, max, count;

int arr[SIZE];

for (int i = 0; i < SIZE; i++)

{

 std::cin >> arr[i]; // вводим элементы массива

 std::cout << arr[i] << "\t"; // выводим массив в консоль

}

std::cin >> regim;

if ((regim > 0) && (regim < 4))

{

 if (regim == 1)

 {

  for (int i = 0; i < SIZE; i++)

  {

   sum += arr[i]; // или sum = sum + arr[i];

  }

  std::cout << "Сумма элементов массива = " << sum << std::endl;

 }

 else if (regim == 2)

 {

  max = arr[0];

  for (int i = 0; i < SIZE; i++)

  {

   if (max < arr[i])

    max = arr[i];

  }

  std::cout << "Максимальный элемент в массиве = " << max << std::endl;

 }

 else

 {

  for (int i = 0; i < SIZE; i++)

  {

   if (arr[i] < 0)

    count++;

  }

  std::cout << "Число отрицательных элементов в массиве = " << count << std::endl;

 }

}

else

 std::cout << "Доступен только 1-3 режим!" << std::endl;

return 0;

}

0,0(0 оценок)
Ответ:
akulkaeva78
akulkaeva78
27.05.2021 07:46

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "");

int N = 10;

int max = -9999999;

int sum = 0;

int choise = 0;

int arr[N] = {0};

cout << "Введите 10 значений: ";

for(int i = 0; i<N; ++i) {

cin >> arr[i];

}

cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";

cin >> choise;

if(choise==1) {

for(int i = 0; i<N; ++i) {

sum+=arr[i];

}

cout << endl << "Сумма: " << sum;

}

if(choise==2) {

for(int i = 0; i<N; ++i) {

if(arr[i]>max) {

max = arr[i];

}

}

 cout << endl << "Макс. знач: " << max;

}

if(choise==3) {

 for(int i = 0; i<N; ++i) {

   if(arr[i]<0) {

     ++sum;

   }

 }

 cout << "Колво отр. знач: " << sum;

}

 if(choise!=1&&choise!=2&&choise!=3) {

   cout << "Введите корректное значение.";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота