В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
skymiss
skymiss
05.08.2022 04:10 •  Информатика

Ребята , с задачей: Задача 9. Пирамидка 2

Напишите программу,

которая получает на вход количество уровней пирамиды и выводит их на экран,

Пример:

1
3 5
7 9 11
13 15 17 19
21 23 25 27 29

Показать ответ
Ответ:
nastyakisa2
nastyakisa2
07.04.2022 02:48
№1
#include iostream
using namespace std;

int main()
{
cout << "2 + 2 = ?" <<end;
int a;
cin >> a;
if(a == 4)cout <<"true"<<endl
else{cout<<"false"<<endl;}
}

№2
#include iostream
using namespace std;

int main()
{
int a,b,c;
cin>>a>>b>>c;
if (a%2==0) a=a*a;
if(b%2==0) b=b*b;
if(c%2==0) c=c*c;
cout <<a<<" "<<b<<" "<<c<<endl;
}

№3
#include <conio.h>
#include <iostream>
using namespace std;

int main()
{
float a, b, c;
cin >> a >> b >> c;
if(a < b && a < c)
cout << a;
else if(b < a && b < c)
cout << b;
else if(c < b && c < a)
cout << c;
_getch();
return 0;
}
0,0(0 оценок)
Ответ:
Aleksey8b
Aleksey8b
11.10.2021 08:51
#include <iostream>
#include <vector>
using namespace std;

int main() {
cout << "Введите вектор (0, чтобы закончить):\n";
float in;
vector<float> a;
while (true) {
cin >> in;
if (in == 0)
break;
else
a.insert(a.end(), in);
}
float p, x, y;
cout << "x = ";
cin >> x;
cout << "y = ";
cin >> y;
p = 1;
for (int i = 0; i < a.size(); i++) {
if ( (a[i] >= x) && (a[i] <= y) )
p *= a[i];
}
cout << "p = " << p << '\n'
<< "a[]:";
for (int i = 0; i < a.size(); i++) {
cout << a[i] << ' ';
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота