В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mansursatuev
mansursatuev
16.04.2023 00:12 •  Информатика

Рекурсивный алгоритм F для удобства записан на пяти языках программирования. Чему равна сумма всех чисел, на экране при выполнении вызова F(1)?


Рекурсивный алгоритм F для удобства записан на пяти языках программирования. Чему равна сумма всех ч
Рекурсивный алгоритм F для удобства записан на пяти языках программирования. Чему равна сумма всех ч

Показать ответ
Ответ:
javajaaripo
javajaaripo
05.01.2021 20:58

Відповідь:

a = 0

def F(n):

   global a

   print(n)

   a += n

   if n < 4:

       F(n + 1)

       F(n + 3)

F(1)

print(a)

1, 2, 3, 4, 6, 5, 4

Сумма данных чисел составляет: 25

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота