В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Shawtyy
Shawtyy
07.09.2022 04:43 •  Информатика

Решать в pascal найти наибольший элемент заданной целочисленной числовой последовательности. входные данные: во входном потоке в первой строке задано натуральное число n (n < = 1000) - количество элементов числовой последовательности. во второй строке через пробел перечислены значения элементов последовательности ai (-32000 < = ai < = 32000). выходные данные: в выходной поток вывести единственное целое число. пример входного файла (input.txt): 8 100 10 -10 -100 300 32000 20000 -30000 пример выходного файла (output.txt): 32000 мое решение(ошибку скажите): var a,b,max,i: longint; begin read(a); for i: =1 to a do begin read(b); if b> =max then max: =b; end; write(max); end.

Показать ответ
Ответ:
alexfuerte07
alexfuerte07
08.10.2020 13:31
Ошибка заключается в том, что переменную max нужно инициализировать прежде, чем будет осуществлен вход в цикл.

var a, b, max, i : longint;
begin
  read(a);
  max := -32001;
  for i:=1 to a do begin
  read(b);
  if b >= max then 
    max:=b;
  end;
  write(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота