В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
prohov14
prohov14
30.06.2022 00:58 •  Информатика

Решение в паскале написать программу, которая уменшнает на 10 введенное с клавиатуры двузначное число, на 100 - если трехзначное. условие окончания программы - введение нулевого числа. уведомление о некорректности данных вывести красным цветом, а про окончание работы - зеленым.

Показать ответ
Ответ:
uztstdgiDima
uztstdgiDima
08.10.2020 21:02
Uses Crt;

var
  n:integer;
 
begin
  repeat
    textcolor(15);
    Write('n='); Read(n);
    if n=0 then begin
      textcolor(LightGreen);
      Writeln('Работа завершена');
      textcolor(15);
      end
    else  
      if (n>9) and (n<100) then begin
        n:=n-10;
        Writeln('Результат: ',n)
        end
      else
        if (n>99) and (n<1000) then begin
          n:=n-100;
          Writeln('Результат: ',n)
          end
        else begin
          textcolor(LightRed);
          Writeln('Недопустимое значение');
          end;
  until n=0;
  ReadKey { для PascalABC.NET можно удалить эту строку }
end.

Решение в паскале написать программу, которая уменшнает на 10 введенное с клавиатуры двузначное числ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота