В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
КитиКэт13
КитиКэт13
26.05.2023 14:08 •  Информатика

Решить 20 ! дано целое число n (0< =n< =9). написать программу, вычисляющую сумму всех двузначных чисел(в записи которых нет цифры n) даны целые числа a и b.написать программу, подсчитывающую сумму двузначных чисел, у которых либо первая цифра равна a, либо вторая цифра равна b. написать программу, определяющую количество трехзначных натуральных чисел, сумма цифр которых равна заданному числу n все через while

Показать ответ
Ответ:
lexazykov20014
lexazykov20014
02.10.2020 10:47
Program tak;
var a,b,c,N:integer;
begin writeln('введите число N (0<=N<=9) ');
 readln(N);
 b:=0; 
for a:=99 downto 10 do  begin 
  if (N <> a div 10) and (N <> a div 10) then 
  b:=a+b; 
 end;
 writeln(b);
end.
эт первая

program tak2;
var a,b,c,d:integer;
begin writeln('введите два числа ');
 readln(a,b);
 d:=0; 
for c:=99 downto 10 do  begin 
  if (a = c div 10) or (b = c mod 10) then 
  d:=c+d;
  end;
 writeln(d);
end.
эт вторая
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота