решить 5 задач на языке программирования Java Script:
1) Входные данные
Вводятся целые числа a и b. Гарантируется, что a не превосходит b
Выходные данные
Выведите (через пробел) все четные числа от a до b (включительно).
Примеры
входные данные
2
5
выходные данные
2 4
2) Входные данные
Вводятся 4 числа: a, b, c и d.
Выходные данные
Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.
Примеры
входные данные
2
5
0
2
выходные данные
2 4
3) Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число).
Входные данные
Вводится натуральное число x
Выходные данные
Выведите все делители числа x
Примеры
входные данные
32
выходные данные
1 2 4 8 16 32
4) Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите наименьший делитель числа x, отличный от 1.
Примеры
входные данные
6
выходные данные
2
5) Входные данные
Вводится число N, а затем N чисел, сумму которых необходимо вычислить.
Выходные данные
Выведите единственное число - сумму введенных чисел.
Примеры
входные данные
3
9
5
1
выходные данные
15
// Внимание! Если программа не работает, обновите версию!
procedure CreateFile(p:string);
begin
var f:=OpenWrite(p);
Writeln(f,'В чащах юга жил бы цитрус? Да, но фальшивый экземпляръ!');
Writeln(f,'СЪЕШЬ ЖЕ ЕЩЁ ЭТИХ МЯГКИХ ФРАНЦУЗСКИХ БУЛОК, ДА ВЫПЕЙ ЧАЮ');
Writeln(f,'ФлегмаТичНая этА веРБлЮдиЦа жует у пОДЪезда засыХающий горький шиповник');
Writeln(f,'The quick brown fox jumps over the lazy dog');
Writeln(f,'THE FIVE BOXING WIZARDS JUMP QUICKLY');
f.Close
end;
procedure UpFile(p:string);
begin
var a:=ReadAllLines(p);
WriteAllLines(p,a.Select(s->UpperCase(s)).ToArray);
end;
begin
var p:=ReadlnString('Введите имя файла (можно, с путём):');
CreateFile(p);
UpFile(p);
// контроль работы
ReadAllLines(p).Println(NewLine)
end.
Пример работы
Введите имя файла (можно, с путём): MyTest.txt
В ЧАЩАХ ЮГА ЖИЛ БЫ ЦИТРУС? ДА, НО ФАЛЬШИВЫЙ ЭКЗЕМПЛЯРЪ!
СЪЕШЬ ЖЕ ЕЩЁ ЭТИХ МЯГКИХ ФРАНЦУЗСКИХ БУЛОК, ДА ВЫПЕЙ ЧАЮ
ФЛЕГМАТИЧНАЯ ЭТА ВЕРБЛЮДИЦА ЖУЕТ У ПОДЪЕЗДА ЗАСЫХАЮЩИЙ ГОРЬКИЙ ШИПОВНИК
THE QUICK BROWN FOX JUMPS OVER THE LAZY DOG
THE FIVE BOXING WIZARDS JUMP QUICKLY
Под аппаратными средствами защиты понимаются специальные средства, непосредственно входящие в состав технического обеспечения и выполняющие функции защиты как самостоятельно, так и в комплексе с другими средствами, например с программными. Можно выделить некоторые наиболее важные элементы аппаратной защиты:
1. защита от сбоев в электропитании;2. защита от сбоев серверов, рабочих станций и локальных компьютеров;
3. защита от сбоев устройств для хранения информации;
4. защита от утечек информации электромагнитных излучений.