В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Wertwer123
Wertwer123
20.07.2021 08:09 •  Информатика

Решить через pascal 1. к финалу конкурса лучшего по профессии "специалист электродорожник" были допущены трое: иванов, петров, сидоров. соревнования проходили в 3 тура. иванов в первом туре набрал m1 , во втором - n1, в третьем - p1. петров соответственно: m2, n2, p2. сидоров: m3, n3, p3. составить программу, определяющую кто победитель и сколько набрал . 2. составить программу, вычисляющую стоимость покупки с учетом скидки: куплено три товара и, если сумма покупки превышает 1500 р., то начисляется скидка 2%

Показать ответ
Ответ:
666deadlyshadow666
666deadlyshadow666
30.09.2021 23:11

4.

program p3;

uses Robot;

procedure Square2;

begin

right;

paint;

down;

paint;

left;

paint;

up;

paint

end;

var i,j:integer;

begin

Task('p3');

for i := 1 to 6 do

begin

Square2;

if i<=5 then

begin

for j := 1 to 2 do left;

for j := 1 to 2 do up      

end

end

end.

5.

program p4;

uses Robot;

procedure Square2;

begin

paint;

right;

paint;

down;

paint;

left;

paint;

up

end;

var i:integer;

begin

Task('p4');

Square2;

for i:= 1 to 2 do right;

Square2;

for i:= 1 to 2 do down;    

Square2;

for i:= 1 to 2 do left;    

Square2;

for i:= 1 to 2 do up

end.

Объяснение:

Второй вариант 5-го задания с двумя процедурами

program p4;

uses Robot;

procedure Square2;

begin

paint;

right;

paint;

down;

paint;

left;

paint;

up

end;

procedure Square;

var i:integer;

begin

Square2;

for i:= 1 to 2 do right;

Square2;

for i:= 1 to 2 do down;    

Square2;

for i:= 1 to 2 do left;    

Square2;

for i:= 1 to 2 do up

end;

begin

Task('p4');

Square

end.

0,0(0 оценок)
Ответ:
dariapark1
dariapark1
30.09.2021 23:11
Const
  eps = 0.001;

function Pow(p: real; n: integer): real;
// возвращает значение p^n
begin
  Pow := exp(n * ln(p))
end;

function Fact(n: integer): real;
// возвращает значение n!
var
  p: real;
  i: integer;
begin
  p := 1;
  for i := 1 to n do p := p * i;
  Fact := p
end;

var
  i: integer;
  a, ai: real;

begin
  a := 0;
  ai := 2 * eps;
  i := 0;
  while ai > eps do
  begin
    i := i + 1;
    ai := Pow(2 / i, i) * Fact(i);
    a := a + ai
  end;
  writeln('Сумма первых ',i, ' членов ряда с точностью ', eps:0:4, ' равна ', a:0:4)
end.

Тестовое решение:

Сумма первых 32 членов ряда с точностью 0.0010 равна 12.9467
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота