Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Zalis1
19.05.2022 01:25 •
Информатика
(решить через паскаль)определить,попадает ли точка а с координатами x и y внутрь круга с радиусом r.центр круга совпадает с началом координат
Показать ответ
Ответ:
nastusa098
28.09.2020 16:45
Var x,y,r:real;
begin
write('x,y: '); readln(x,y);
write('R: '); readln(r);
if x*x+y+y<r*r
then writeln('Точка находится внутри круга')
else writeln('Точка не находится внутри круга');
end.
Пример:
x,y: 1 2
R: 3
Точка находится внутри круга
0,0
(0 оценок)
Популярные вопросы: Информатика
dasha21k2
23.03.2023 22:01
На JavaScript сделать 6 окон которые будут выходить в последовательности. Введите свою фамилию, Введите свое имя, Введите свое отчество, потом: Запросите подтверждение (Иван Иванович...
simpson12345
05.02.2023 08:27
не с интернета а своё, именно не с интернета) придумайте пример задачи решаемой на компьютере и назовите для нее исходные промежуточные и итоговые данные...
olleandro
04.06.2022 21:30
Задание по паскалю. Дан массив из 4х4 вещественных (дробных) чисел. Напишите программу вычисления суммы квадратов дробных частей у элементов массива стоящих выше главной диагонали....
atchaschinovр
29.04.2020 04:50
Процес виконується в нескінченному циклі. За до якого апаратного пристрою операційна система може перехопити керування в цього процесу?...
васеня220044
12.01.2020 06:31
Почему перед пересылкой текстового файла по электронной почте имеет смысл его упаковать в архив?...
kaamazon
23.02.2023 08:24
Какие файлы не имеет смысла архивировать?...
batya757757
27.03.2022 05:45
По информатики ! нужно некоторые сведенья о деревьях о тополе и о клене! зарание ! : ; -)...
fedos1488
22.07.2022 07:54
Задать факториал в паскале: 3! 5! 7!...
thienla0
12.06.2022 23:30
Нужно через подобие Дано треугольник ABC и MBNMN=4AC=9BN=6-XНайти NC...
Срочный103
25.10.2022 05:28
На рисунке изображен график движения туриста.Рассматривая график,определите на каком расстоянии от дома турист был через четыре часа?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
write('x,y: '); readln(x,y);
write('R: '); readln(r);
if x*x+y+y<r*r
then writeln('Точка находится внутри круга')
else writeln('Точка не находится внутри круга');
end.
Пример:
x,y: 1 2
R: 3
Точка находится внутри круга