Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
SvetaMew
07.11.2021 02:58 •
Информатика
Решить: через паскаль составить таблицу значений функции y=5-x²/2 на отрезке [a; b] с шагом 1. ( решите, используя цикл с параметром). : )
Показать ответ
Ответ:
73021081
03.10.2020 15:45
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var a,b:integer;
Write('Введите a и b: '); Read(a,b);
for var x:=a to b do Writeln(x:5,5-x*x/2:8:1)
end.
Тестовое решение
Введите a и b: -5 10
-5 -7.5
-4 -3.0
-3 0.5
-2 3.0
-1 4.5
0 5.0
1 4.5
2 3.0
3 0.5
4 -3.0
5 -7.5
6 -13.0
7 -19.5
8 -27.0
9 -35.5
10 -45.0
0,0
(0 оценок)
Популярные вопросы: Информатика
MDA142rus
15.12.2020 11:21
Дана программа:Program Primer;VarN,result : real;Begin Writeln( Введите значения переменной N ); Write( N= ); Readln(N); Result := sqr((7+N)*4); Writeln ( sqr((7+N)*4) , result:8:0);...
Приветусик11
13.11.2021 15:55
Дан фрагмент таблицы «Товар на складе». Введи данные в MS Excel и вычисли стоимость всего товара на складе. 1 Товар Цена за 1 шт. (руб.) 2 Пальто 6798,3 3 Куртка 2263 4 Шуба 24691,9...
ilmir14
20.10.2022 14:57
Составить блок-схемы решения : 1). Формула разности квадратов. 2). Проверить: не равен ли нулю знаменатель, вычислить дробь. 3). Нахождение факториала числа n....
pudgenamide
12.05.2021 12:38
ПИТОН Рассмотрим ряд:14=11∗3−12∗4+13∗5−...+(−1)n+1n∗(n+2)+...Выведите на экран сумму первых 6 членов этого ряда (то есть сумму первых шести слагаемых в данном выражении).без циклов...
дэньчик4
14.04.2021 01:17
Який вигляд має блок-схема циклу з лічильником? поясніть виконання фрагмента алгоритму ....
mneo98
18.07.2021 04:30
Создайте поле размером 7 на 7. Составьте программу, в результате которой робот закрасит диагональные и вертикальные клетки поля. Исходное положение Робота и результат выполнения...
Elv26
24.03.2022 12:08
Seri 8rutgtrj gfojog odg?...
юююю20
22.11.2022 12:11
Информатика связанная со звуком нотами и прочее. ответьте на вопрос...
korolnn
22.11.2020 16:19
Выражение на языке Паскаль выглядит так: abs(sqr(z)−5∗z+7). Как выглядит данное выражение на математическом языке?...
vitay123
29.12.2020 23:31
РЕШИТЬ В PYTHON. Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
var a,b:integer;
Write('Введите a и b: '); Read(a,b);
for var x:=a to b do Writeln(x:5,5-x*x/2:8:1)
end.
Тестовое решение
Введите a и b: -5 10
-5 -7.5
-4 -3.0
-3 0.5
-2 3.0
-1 4.5
0 5.0
1 4.5
2 3.0
3 0.5
4 -3.0
5 -7.5
6 -13.0
7 -19.5
8 -27.0
9 -35.5
10 -45.0