В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
eeeevaa
eeeevaa
21.06.2020 11:31 •  Информатика

Решить, : дана температура за 7 дней года и за эти же 7 дней этого года.написать программу, позволяющую определить, повысилась или понизилась температура за неделю, по сравнению с годом

Показать ответ
Ответ:
Touka1337
Touka1337
16.06.2020 08:14

Program Maslovaalisa;
const n=7;
var last: array[1..n] of integer;
var new: array[1..n] of integer;
i: integer;
begin
  writeln('');
  for i:=1 to n do
  begin
    writeln('Введите температуру за ',i,'-й день недели: ');
    write('  - в году  ');readln(last[i]);
    write('  - в этом году  ');readln(new[i]);
   end;
  writeln('*** alphaues is thinking... ***');
  writeln();
  for i:=1 to n do
  begin
    if last[i] > new[i] then
writeln('В ',i,'-й день недели в году было теплее, чем в этом. Бр-р-р...')
    else
      if last[i] < new[i] then
writeln('В ',i,'-й день недели в году было холоднее, чем в этом. Уф-ф-ф...')
        else
writeln('Удивительно! В ',i,'-й день недели в году была такая же температура, как в этом!');
  writeln('');
  end;
end.

0,0(0 оценок)
Ответ:
leratsvetik
leratsvetik
16.06.2020 08:14
Можешь создать 2 массива для температур этого года и а потом сравнивать элементы с одинаковыми индексами( с
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота