Решить) для каждого рисунка написать программу, используя логические выражения, которая выводит true, если точка принадлежит заштрихованной области, и false в противном случае.
Домбра - самый любимый и самый распространенный инструмент в музыкальном быту казахов. Казахская домбра - это щипковый двухструнный инструмент, изготовленный из цельного дерева. Применяется и как аккомпонирующий, и как сольный, и как основной инструмент в казахской народной музыке. Домбра не утратила своей актуальности и по сегодняшний день. Многие современные музыканты включают в свои композиции звучание домбры.
Конструкция казахской домбры немного отличалась в зависимости от региона. Так на западе, в Прикаспийских степях домбра имела округлую каплевидную форму с тонкой длинной шейкой. Лады-перевяз перне, как и струны, изготавливались из бараньих или козлиных кишок. В центальных и восточных регионах Казахстана домбры делались с плоской нижней декой и короткой, толстой шейкой. Чаще вего домбра изготавливалась из цельных кусков дерева : ели, клена, чинара, но встречаются и клееные экземпляры домбры. На восточно-казахстанских домбрах навязывались 7-9 ладов, что обеспечивало игру аккомпанемента или исполнение песенных мелодий.
На казахском:
Домбыра - қазақтардың музыкалық өміріндегі ең сүйікті және кең таралған құрал. Қазақтың домбырасы - қатты ағаштан жасалған екі ішекті аспап. Ол қазақ халқының музыкасында негізгі, жеке құрал ретінде қолданылады. Домбыра бүгінгі күнге дейін өзектілігін жоғалтқан жоқ. Көптеген заманауи музыканттар өз шығармаларына домбыраны қосады.
Қазақ домбырасының дизайны аймаққа байланысты аздап ерекшеленді. Сонымен батыста, Каспий даласында домбыраның домалақ пішіні жұқа ұзын мойны бар еді. Перне шпаты, ішекті тәрізді, қошқар немесе ешкі ішектерінен жасалған. Қазақстанның орталық және шығыс аймақтарында домбыралар жалпақ төменгі палубамен және қысқа, қалың мойынмен жасалды. Көбінесе домбыра ағаштың барлық бөліктерінен жасалынған: шырша, үйеңкі, шыбын, бірақ домбыраның желімделген үлгілері де кездеседі. Шығыс Қазақстандық домбырада сүйемелдеу мен ән әуендерін орындауды қамтамасыз ететін 7–9 фрагтар орнатылды.
На русском:
Домбра - самый любимый и самый распространенный инструмент в музыкальном быту казахов. Казахская домбра - это щипковый двухструнный инструмент, изготовленный из цельного дерева. Применяется и как аккомпонирующий, и как сольный, и как основной инструмент в казахской народной музыке. Домбра не утратила своей актуальности и по сегодняшний день. Многие современные музыканты включают в свои композиции звучание домбры.
Конструкция казахской домбры немного отличалась в зависимости от региона. Так на западе, в Прикаспийских степях домбра имела округлую каплевидную форму с тонкой длинной шейкой. Лады-перевяз перне, как и струны, изготавливались из бараньих или козлиных кишок. В центальных и восточных регионах Казахстана домбры делались с плоской нижней декой и короткой, толстой шейкой. Чаще вего домбра изготавливалась из цельных кусков дерева : ели, клена, чинара, но встречаются и клееные экземпляры домбры. На восточно-казахстанских домбрах навязывались 7-9 ладов, что обеспечивало игру аккомпанемента или исполнение песенных мелодий.
На казахском:
Домбыра - қазақтардың музыкалық өміріндегі ең сүйікті және кең таралған құрал. Қазақтың домбырасы - қатты ағаштан жасалған екі ішекті аспап. Ол қазақ халқының музыкасында негізгі, жеке құрал ретінде қолданылады. Домбыра бүгінгі күнге дейін өзектілігін жоғалтқан жоқ. Көптеген заманауи музыканттар өз шығармаларына домбыраны қосады.
Қазақ домбырасының дизайны аймаққа байланысты аздап ерекшеленді. Сонымен батыста, Каспий даласында домбыраның домалақ пішіні жұқа ұзын мойны бар еді. Перне шпаты, ішекті тәрізді, қошқар немесе ешкі ішектерінен жасалған. Қазақстанның орталық және шығыс аймақтарында домбыралар жалпақ төменгі палубамен және қысқа, қалың мойынмен жасалды. Көбінесе домбыра ағаштың барлық бөліктерінен жасалынған: шырша, үйеңкі, шыбын, бірақ домбыраның желімделген үлгілері де кездеседі. Шығыс Қазақстандық домбырада сүйемелдеу мен ән әуендерін орындауды қамтамасыз ететін 7–9 фрагтар орнатылды.
#include <iostream>
#include <fstream>
#include <cmath>
using namespace std;
int main()
{
int a[5][5] = { 0 }, i, j, s, b[5] = { 0 };
double p;
ifstream f("input.txt");
if (!f.is_open())
cout << "error";
else
{
for (i = 0; i < 5; i++)
for (j = 0; j < 5; j++)
f >> a[i][j];
}
f.close();
s = 0;
for (i = 0; i < 5; i++)
if(a[i][i]<0)
s += a[i][i];
cout << "sum=" <<s<<endl;
p = 1;
for (int j = 0; j < 5; j++)
p *= 2*sin(abs(a[3][j]))+0.3*j;
cout << "P=" << p << endl;
s = 0;
for (j = 0; j < 5; j++)
{
for (i = 0; i < 5; i++)
if(a[i][j]>0)
s += a[i][j];
b[j] = s;
s = 0;
}
cout << "massiv b: ";
for (i = 0; i < 5; i++)
cout << b[i] << " ";
return 0;
}