В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
yopof195Pro
yopof195Pro
18.11.2021 22:58 •  Информатика

Решить и написать программу на C#
Задача «Сколько каких дорог?»
В городе Новые Васюки на некоторых дорогах введено одностороннее движение. Схема дорог задана в виде весовой матрицы графа, числа обозначают длины дорог. Если длины дорог из пункта А в пункт Б разные, это означает, что есть две разные дороги. Найдите отдельно количество дорог в Новых Васюках с односторонним и двусторонним движением.

Входные данные
В первой строке вводится количество перекрёстков в Новых Васюках N ( 1 ≤ N ≤ 1000 ). В следующих N строках записано по N чисел, разделённых пробелами – длины дорог между каждой парой перекрёстков. Ноль означает, что дороги между этими перекрёстками нет.

Выходные данные
Программа должна вывести два числа в одной строке, разделив их пробелом: сначала количество дорог с односторонним движением, потом – количество дорог с двусторонним движением.

Примеры
входные данные
5
0 2 3 4 0
2 0 5 0 7
3 6 0 8 0
0 0 0 0 0
0 7 0 9 0
выходные данные
5 3

Показать ответ
Ответ:
Liza1556
Liza1556
18.12.2022 17:52

program podriad_idu_na_0;

var

n, x, k, k2:integer;

f:boolean;

begin

read(x);

f:=false;

repeat

if (f=false) and (x mod 10=0) then

begin

f:=true;

k:=k+1;

end

else

if (x mod 10=0) then

k:=k+1

else

begin

if k>k2 then

k2:=k;

k:=0;

f:=false;

end;

read(x);

until x=0;

write(k2);

readln;

end.

program proverka_na_ubivanie;

var

x,t:integer;

begin

read(x);

t:=x mod 10;

x:=x div 10;

while (x > 0) and ( t<x mod 10) do

x:=x div 10;

if x=0 then

write('Да')

else

write('Нет')

end.

program chisla_princip_piki_jami;

var

x,p:integer;

f:boolean;

begin

read(x);

f:=false;

if x>10 then

begin

if (x mod 10)>(x div 10 mod 10) then

p:=1

else

if (x mod 10)<(x div 10 mod 10) then

p:=0

else f:=true;

x:=x div 10;

while (x>10)and(f=false)

do

begin

if ((x mod 10)>(x div 10 mod 10) )and(p=0)then

p:=1

else

if ((x mod 10)<(x div 10 mod 10) )and(p=1)then

p:=0

else f:=true;

x:=x mod 10;

end;

if f=true then write('Нет')

else write('Да')

end

else

write('Слишком маленькое число')

end.

0,0(0 оценок)
Ответ:
Вадим8383
Вадим8383
02.01.2023 07:55

x1 ≈ 2,3

x2 ≈ - 1,3

Смотри картинки

Объяснение:

1) В ячейку B1 пишем y = x*x - 2

2) В ячейку C1 пишем y = x + 1

3) В ячейку A2 пишем x

4) В ячейку B2 пишем y

5) В ячейку C2 пишем y

6) В ячейку A3 пишем -1,5

7) В ячейку A4 пишем -1,25

8) Выделите ячейки А3 и А4 в правом нижнем углу появится зелёный квадратик, а рядом с ним квадратик с выпадающим списком, в котором надо выбрать Заполнение. Потяните за зелёный квадратик вниз до А19.

9) В ячейку В3 пишем формулу = A3*A3-2

10) Копируем ячейку В3, выделяем диапазон В4:В19 и вставляем эту формулу

11) В ячейку С3 пишем формулу =A3+1

12) Копируем ячейку С3, выделяем диапазон С4:С19 и вставляем эту формулу

13) Выделяем диапазон А2:С19 выбираем вкладку Вставка, затем Диаграмма, Точечная. Появляется график.

14) По графику смотрим координаты х в точках пересечения графиков.

15) В ячейку N5 пишем x1 ≈ 2,3

16) В ячейку N6 пишем x2 ≈ - 1,3


сделать домашнее задание в Excel ,построить параболу
сделать домашнее задание в Excel ,построить параболу
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота