В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
duy53519
duy53519
02.11.2020 16:38 •  Информатика

Решить на любом языке программирования. имеется ряд из n лампочек, которые пронумерованы от 1 до n. изначально ни одна из лампочек не горит. далее происходит k последовательных линейных инверсий этого ряда ламп. под линейной инверсией понимается инверсия каждой p-й лампочки в ряде. например, если p=3, то произойдет инверсия 3й, 6й, 9й и т.д. лампочек.требуется определить: сколько горящих лампочек останется после реализации всех заданных линейных инверсий? входные данные: в первой строке входного файла input.txt заданны числа n и k – число лампочек и число линейных инверсий. вторая строка состоит из k целых чисел pi, период данных инверсий. (1 < = n < = 109, 1< =k< =100, 1 < = pi < = 50) выходные данные в выходной файл output.txt следует вывести ответ на .

Показать ответ
Ответ:
Янина7005
Янина7005
21.06.2020 05:45
Package test;
import java.io.*;
public class Test {    public static void main(String[] args) throws IOException {         BufferedReader in=new BufferedReader(new InputStreamReader(System.in));
String line = in.readLine();
int N = Integer.parseInt(line);
boolean[] mas = new boolean[N];        
String line2 = in.readLine();       
int K = Integer.parseInt(line2);        
for(int x = 0; x < N; x++){mas[x]=false;}        
for(int z = 0; z < K; z++){String line1 = in.readLine();
            int P = Integer.parseInt(line1);
            for(int i = P - 1; i < N; i = i + P){if (mas[i] == false) {mas[i]=true;}               
                                                         else mas[i] = false;
            }       
}        
for(int l = 0; l < N; l++){if(mas[l]==true){System.out.println("+");}
else System.out.println("-");        }    }}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота