В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dendemintsev
dendemintsev
03.04.2022 08:54 •  Информатика

Решить на паскаль с постусловием дано натуральное число m. написать программу для вычисления первой цифры числа m. входные данные 54321 выходные данные 5. дано натуральное число m. написать программу для вычисления второй цифры числа м(m> 10) входные данные 54321 выходные данные 4.

Показать ответ
Ответ:
llerochka1
llerochka1
04.10.2020 05:18
Var
    m, i: integer;
    a: array[1..10] of integer;

begin
    readln(m);
    i := 0;
    repeat
        i := i + 1;
        a[i] := m mod 10;
        m := m div 10;
    until m = 0;
    
    writeln('Первая цифра ', a[i]);
    writeln('Вторая цифра ', a[i - 1]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота