В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Egor222222222
Egor222222222
10.04.2020 00:09 •  Информатика

Решить на паскале.
с клавиатуры вводятся координаты точки на плоскости (x, y – действительные числа. написать программу, определяющую принадлежность точки заштрихованной области, включая ее границы.

Показать ответ
Ответ:
салссо1232960
салссо1232960
10.10.2020 10:08

program Test;

var

 x, y: Double;

begin

 WriteLn ('Введите координаты x и y: ');

 ReadLn (x, y);

 if (x >= 0) and (x <= Pi) and (y >= 0) and (y <= 0.5) and (y <= Sin (x)) then

   WriteLn ('Принадлежит')

 else

   WriteLn ('Не принадлежит');

 ReadLn;

end.

Объяснение:

Первые 4 условия проверяют прямоугольник от (0, 0) до (п, 0,5)

последнее условие проверяет левый и правый край этого прямоугольника на принадлежность к графику Sin (x)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота