В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Решить на Питоне
n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1.
Входные данные Программа получает на вход числа n и k. Выходные данные Программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей.
Примечание: При решении этой задачи нельзя пользоваться условной инструкцией if и циклами.

Примеры:

входные данные: 7, 30
выходные данные: 5

входные данные: 7, 28
выходные данные: 0

Показать ответ
Ответ:
maksimmaksegoroysa5l
maksimmaksegoroysa5l
17.08.2020 20:57

Объяснение:

Решить на питоне не могу, но могу дать тебе кусок кода и объяснить его.

int n,k,a;   //объявляешь переменные n,k,a

cin>>n>>k;  //считываешь с клавы

a = (n-k%n)%n;  //находишь a, где % это остаток от деления

cout<<a; //выводишь a

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота