В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
areskinaelina
areskinaelina
25.11.2021 03:43 •  Информатика

Решить на Python при строки, задачу следующего типа: Введите с клавиатуры текст и определите, какой символ встречается чаще всего. Если таких символов несколько, выведите их все

Показать ответ
Ответ:
hohlovm71
hohlovm71
08.01.2023 08:15

Решение. Обозначим высказывательную форму "юноша по имени А носит фамилию Б" как АБ, где буквы А и Б соответствуют начальным буквам имени и фамилии.

Зафиксируем высказывания каждого из друзей:

ДМ   и   БХ; АМ   и   ВБ; ВТ   и   БМ; ВБ   и   ГЧ; ГЧ   и   АТ.

Допустим сначала, что истинно ДМ. Но, если истинно ДМ, то у Антона и у Бориса должны быть другие фамилии, значит АМ и БМ ложно. Но если АМ и БМ ложны, то должны быть истинны ВБ и ВТ, но ВБ и ВТ одновременно истинными быть не могут.

Значит остается другой случай: истинно БХ. Этот случай приводит к цепочке умозаключений: 
  
БХ истинно  БМ ложно  ВТ истинно  АТ ложно  ГЧ истинно  ВБ ложно  АМ истинно.

ответ: Борис — Хохлов, Вадим — Тихонов, Гриша — Чехов, Антон — Мишин, Дима — Белкин.

0,0(0 оценок)
Ответ:
zero407
zero407
06.07.2021 04:58

1)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
 
int main()
{
    char s[20];

    cout << "What is your name: ";
    cin >> s;

    cout << "Hello, " << s << endl;
 
   return 0;
}

 

2)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = strlen(s) - 1; i >= 0; i--)
    {
        cout << s[i];
    }
    cout << endl;
 
   return 0;
}

 

3)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[20];
    bool x = true;

    cout << "Enter the word: ";
    cin.getline(s, 100);

    for(int i = 0, j = strlen(s) - 1; i <= j; i++, j--)
    {
        if(s[i] != s[j])
        {
            x = false;

            break;
        }
    }

    if(x)
    {
        cout << "Palindrome" << endl;
    }
    else
        cout << "Not palindrome" << endl;
 
   return 0;
}

 

4)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];
    char n;

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = 0; i < strlen(s); i++)
    {
        if(s[i] == 'a')
        {
            n = 'a';

            break;
        }
        else if(s[i] == 'o')
        {
            n = 'o';

            break;
        }
    }

    if(n == 'a')
    {
        cout << "\nThe first letter of A" << endl;
    }
    else if(n == 'o')
    {
        cout << "\nThe first letter of O" << endl;
    }
    else
        cout << "These letters are not available" << endl;
 
   return 0;
}


1)написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)написать программу
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота