В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
АлисаAprel
АлисаAprel
15.02.2020 09:34 •  Информатика

решить на языке Паскаль:
В кафе мороженое продают по три шарика и по пять шариков. Можно ли купить ровно k шариков мороженого?
Напишите программу, в которой вводится с клавиатуры число k и выводится на экран ответ на поставленный
во

Показать ответ
Ответ:
xotmirov1
xotmirov1
11.01.2023 15:19

1-й этап

Дано:

а — сумма, получаемая продавцом с продажи каждой из первых 50 газет;

1,2 ⋅ а — сумма, получаемая продавцом с продажи каждой из последующих газет.

Найти:

s — общую сумму, которую получит продавец с продажи 200 газет.

2-й этап

Для нахождения s можно вычислить значение следующего выражения:

50 ⋅ а + 150 ⋅ 1,2 ⋅ а.

Здесь а и s — величины вещественного типа.

3-й этап

Блок-схема

4-й этап

program n_12_63;

var a, s: real;

begin

writeln (‘Подсчет заработка продавца’);

writeln (‘Ввод а‘);

readln (a);

s:=50*a+150*1.2*a;

writeln (‘Продавец заработал ‘, s,’ руб.’)

end.

5-й этап

Протестировать программу можно по следующим данным:

а = 1,

s = 230.

Объяснение:

0,0(0 оценок)
Ответ:
хорошист536
хорошист536
31.01.2021 14:34

ответ:Пример 1. Составить алгоритм запуска программы Paint в ОС Windows 7.

Вспомним из курса информатики 5 класса порядок действий для запуска программы Paint.

Войти в меню «Пуск».

Войти в пункт «Все программы».

Войти в пункт «Стандартные».

Выбрать программу «Paint».

Данный алгоритм в виде блок-схемы имеет следующий вид:

 

Рис. 1. Блок-схема к примеру 1.

 

Составление алгоритмов с ветвлениями

Рассмотрим пример на составление алгоритмов с ветвлениями.

Пример 2. Составьте алгоритм для перехода дороги на светофоре.

Рис. 2. Светофор (Источник).

Возможны следующие ситуации: в тот момент, когда мы подошли к дороге горел красный или зелёный свет. Если горел зелёный свет, то можно переходить дорогу. Если же горел красный свет, то необходимо дождаться зелёного – и уже тогда переходить дорогу.

Таким образом, алгоритм имеет следующий вид:

Подойти к светофору.

Посмотреть на его свет.

Если горит зелёный, то перейти дорогу.

Если горит красный, то подождать, пока загорится зелёный, и уже тогда перейти дорогу.

Блок-схема данного алгоритма имеет вид:

Рис. 3. Блок-схема к примеру 2.

 

Составление циклических алгоритмов

Рассмотрим пример на составление циклического алгоритма. Мы уже несколько раз обсуждали перевод чисел из десятичной системы в двоичную. Теперь пришло время чётко сформулировать этот алгоритм.

Напомним, что его принцип состоит в делении числа на 2 и записей остатков, получающихся при делении.

Пример 3. Составить алгоритм перевода чисел из десятичной системы в двоичную.

То есть, алгоритм будет выглядеть так:

Если число равно 0 или 1, то это и будет его двоичное представление.

Если число больше 1, то мы делим его на 2.

Полученный остаток от деления записываем в последний разряд двоичного представления числа.

Если полученное частное равно 1, то его дописываем в первый разряд двоичного представления числа и прекращаем вычисления.

Если же полученное частное больше 1, то мы заменяем исходное число на него и возвращаемся в пункт 2).

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота