В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
amura20
amura20
18.05.2020 01:03 •  Информатика

решить на языке програмирования PASCAL ABC.
Напишите программу, которая запрашивает у пользователя числа и находит их сумму. Признаком окончания ввода является число 10.
Вход
5 6 2 10 8
Выход
13 (это сумма чисел 5, 6, 2. 10 – это конец цикла).
Заранее благодарю

Показать ответ
Ответ:
oksa4va
oksa4va
14.10.2020 19:40

var

ch,sum:LongInt;

begin

ReadLn(ch);

sum:=0;

while (ch>10) or (ch<10) do

begin

inc(sum, ch);

ReadLn(ch);

end ;

WriteLn(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота