В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Решить Pascal. На листке. Именно на листке,как задачу
Задача 1. Написать программу, выводящую на экран в столбец все чётные числа из промежутка от 100 до 150.

Задача 2. Написать программу, выводящую на экран в столбец все целые числа из промежутка от 100 до 999, которые делятся на число 11.

Показать ответ
Ответ:
Zaichikfoto
Zaichikfoto
26.10.2020 16:52
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    cout << "Enter size of array: ";
    int N;
    cin >> N;
    int * ARR = new int[N];
    srand(time(0));
    int i;
    for (i = 0; i < N; ++i)
        ARR[i] = rand() % 100 + 1;

    cout << "Here is an original array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    int temp = ARR[N - 1];
    for (i = N - 1; i > 0; --i)
        ARR[i] = ARR[i - 1];
    ARR[0] = temp;

    cout << "\nHere is a new array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    return 0;
}
0,0(0 оценок)
Ответ:
frautatyana20
frautatyana20
03.01.2020 05:36
Возможный вариант в C++
#include <iostream>
int main()
{
    using namespace std;
    int N;
    cout << "Enter N: ";
    cin >> N;
    int num;
    int max = 1;
    int i;
    for (i = 0; i < N; ++i)
    {
        cout << "Enter #" << i + 1 << " number: ";
        cin >> num;
        if ((num - 9) % 10 != 0 && num % 3 == 0)
        {
            max = num;
            break;
        }
    }
    for (int j = i + 1; j < N; ++j)
    {
        cout << "Enter #" << j + 1 << " number: ";
        cin >> num;
        if ((num - 9) % 10 != 0 && num % 3 == 0)
            if (num > max)
                max = num;
    }
    if (max != 1)
        cout << "Max number div by 3 and don't end 9: " << max << endl;
    else
        cout << "No numbers div by 3 and don't end 9" << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота