В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
123456sa
123456sa
20.11.2020 19:11 •  Информатика

Решить по икт. 39. составьте программу вычисления длины боковой стороны равнобедренного треугольника, у которого площадь равна s, а длина основания в три раза больше длины высоты, опущенной на него.

Показать ответ
Ответ:
www6363901fs
www6363901fs
07.10.2020 06:07
Площадь треугольника - s = a*h/2
a = 3*h ⇒ s = 3*h*h/2 ⇒ h = √(2*s/3)
Искомая боковая сторона треугольника - это гипотенуза треугольника со сторонами a/2 (=3*h/2)  и h ⇒ b^2 = (3*h/2)^2+h^2

var s,b,h:real;
begin
readln(s);
h:=sqrt(2*s/3); //s:=3*h*h/2
b:=sqrt(13)*h/2; // b^2 =(3*h/2)^2+h^2
writeln('a = ',3*h:5:2,' h = ',h:5:2);
writeln('b = ',b:5:2);
end.

Пример:
16
a = 9.80 h = 3.27
b = 5.89
0,0(0 оценок)
Ответ:
smolyarrrovav
smolyarrrovav
07.10.2020 06:07
На PascalABC.
(20 символов аиыоалокуаикуцлокиуцоауц)
Решить по икт. 39. составьте программу вычисления длины боковой стороны равнобедренного треугольника
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота