В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ckorpid
Ckorpid
29.09.2020 17:17 •  Информатика

Решить по информатике! 25 составить программу,которая определяет сколько слагаемых должно быть в сумме последовательности 2+4+6+8+.. и эта сумма оказалась больше заданного числа n. n> =0паскаль,8 класс!

Показать ответ
Ответ:
Gulnarhidayetova
Gulnarhidayetova
07.06.2020 19:16

var

 i, c, s, n:integer;

Begin

 write('Введите n: ');

 readln(n);

 s:= 0;

 c:= 0;

 write('Последовательность: ');

 while i < n do begin

   s:= s + i;

   c:= c + 1;

   i:= i + 2;

   write(i, ' ');

 end;

 writeln;

 writeln('Сумма последовательности: ', s);

 writeln('Количество слагаемых: ', c);

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота